Questão Por que a Virtual Box não me dará a opção de criar convidados de 64 bits?


Meu host é x64 bits do Windows 8.1.

Eu baixei o último Virtual Box (4.3) e estou tentando criar uma VM com um sistema operacional Ubuntu de 64 bits (ubuntu-12.04.3-desktop-amd64).

Quando vou ao assistente de Nova VM, não me é dada a opção de selecionar "Ubuntu (x64)" como vi nas capturas de tela de outras pessoas, apenas no "Ubuntu". Como resultado, o ISO não pode inicializar. Eu tentei em outro PC e Virtual Box dá as variantes x64 para a maioria dos sistemas operacionais listados ...

Painel de Controle mostra x64 OS, processador x64. Meu laptop host é um processador Sony Vaio VPCZ22UGX / N, processador Intel Core i7-2640M. CPUz mostra Vx-t está disponível no meu processador, é claro.

Aqui está o que eu tentei até agora:

  • Eu habilitei o IO APIC conforme exigido nos documentos.

  • Eu tenho virtualização ativada no BIOS. Funciona bem no VMware.

  • Verifique se o Hyper-V não está em execução ou instalado no meu Windows. O mesmo para o VMware.

  • Eu também tentei executar o comando:

    VBoxManage modifyvm [vmname] --longmode em

para essa VM, mas nenhuma mudança .. Eu acho que o problema é que eu não posso selecionar a variante x64 do sistema operacional Ubuntu para essa VM. Outras pessoas parecem indicar que é um requisito, mas não obtenho essa opção por algum motivo.

Passei muito tempo e não consigo encontrar o que está errado ... Alguém sabe o que pode estar faltando aqui?

Muito obrigado!!

Eduardo


82


origem


O que acontece se você criar uma máquina Ubuntu (x84), então vá para suas configurações, página básica e veja as opções? - JohnLBevan
Pelo que você tentou até agora, eu suspeito que você já viu isso, mas no caso de não: forums.virtualbox.org/viewtopic.php?f=6&t=57926 - JohnLBevan
@ JohnLBevan Eu recebo apenas as opções do x86 .. não posso alterá-lo para x64. Eu acho que você está certo, eu estou acertando esse problema .. exceto que o cara corrigiu desativando o hyper-v e eu não tenho desinstalado. - Edy Bourne
Dê uma olhada neste post: superuser.com/questions/367290/… - computador diferente, mas possivelmente solução semelhante? - JohnLBevan
Oi @JohnLBevan, obrigado pela sua resposta! Infelizmente eu já habilitei o VT-x na BIOS, sem alterações .. Estou pensando em voltar ao VMware e tentar novamente com uma versão mais nova do VirtualBox em algum momento no futuro. - Edy Bourne


Respostas:


Eu tive o mesmo problema.

Desligar o Hyper-v temporariamente resolveu meu problema e todas as opções de 64 bits estavam disponíveis:

Eu uso hyper-v no meu laptop. Quando eu sei que não preciso de VMs para o dia,   Eu posso extrair um pouco mais de desempenho da máquina girando   hyper-v off com:

bcdedit / set hypervisorlaunchtype off

e uma reinicialização. Para ligá-lo novamente:

bcdedit / set hypervisorlaunchtype on (ou auto start)

e reinicie.

Fonte


45



Isso me ajudou também.Citação: "Eu uso hyper-v no meu laptop. Quando eu sei que não preciso de VMs para o dia, posso extrair um pouco mais de desempenho da máquina, desativando o hyper-v com: bcdedit / set hypervisorlaunchtype off e uma reinicialização. Para ligá-lo novamente: bcdedit / set hypervisorlaunchtype on (ou auto start) e reinicialize. " - derFunk
Existe uma solução sem reiniciar? - AlikElzin-kilaka
Estranho, o Hyper-V está desativado no BIOS. Mas de alguma forma esta opção funcionou para mim no Windows 8.1 - spankmaster79
não funcionou para mim. executando o windows 8.1 O que é mais eu não posso configurá-lo depois que eu desliguei. Eu recebo "Os dados inteiros não são válidos como especificado. Execute" bcdedit /? "Para assistência de linha de comando. O parâmetro está incorreto." - Xitcod13
Isso significa que não podemos usar o Windows Phone Emulator por toda a vida! :( para usar o sistema operacional virtual de 64 bits? - Milson


Eu tive o mesmo problema (hardware compatível, opções ativadas - nenhuma maneira de criar uma VM de 64 bits), e desisti do VirtualBox e experimentei o VMWare Workstation. Felizmente, tive um erro semelhante, ainda que explícito, que me pediu para desinstalar o Hyper-V. Desativar isso não é suficiente, você tem que remover o componente do seu sistema. Este post foi útil para mim: Desinstalando o HyperV do Windows 8

Para remover o componente, simplesmente execute este comando e admin cmd (créditos para @ levi-botelho):

Dism /online /disable-feature /featurename:Microsoft-Hyper-V

16



Não tenho certeza do que o Hyper-V tem a ver com isso nem por que ele foi habilitado, mas desabilitá-lo corrigiu isso para mim. Agora há opções de 64 bits para sistemas operacionais convidados. - ub3rst4r
excelente! finalmente encontrei a solução. não conseguia se lembrar de habilitar o hyper-v e definitivamente não sabia que isso teria causado a ocultação das opções de 64 bits no virtualbox - George
Remover o HyperV apenas resolveu isso de mim, embora eu removido do painel de controle. Eu não habilitei, eu acho que alguma ferramenta, driver ou atualização do Windows fez. Eu já tinha máquinas 64x feitas, elas não rodavam até eu me livrar do HyperV. - Theraot
Esta solução funcionou para mim depois de 3 dias de frustração. Muito obrigado. - Jdbaba


Os processadores VT-x / AMD-v são o caminho a percorrer.

Vejo esta postagem para mais detalhes.

Eu consegui ativou esse recurso no meu Thinkpad T420.


14



Obrigado pela sua resposta. Eu tenho um processador Intel® Core i7-2640M. O CPUz mostra que o Vx-t está disponível no meu processador ... o mistério continua ... hehe, neste ponto, estou de volta com o VMware, mas mudarei para a Virtual box se uma solução para isso for encontrada. - Edy Bourne
@EduardoBorn Você pode precisar verificar as opções no BIOS. Eu habilitei este recurso de hardware via BIOS. - Kane
Para mim, a chave para obter este trabalho e as opções de 64 bits a serem exibidas foi ativar o Config -> CPU -> "Intel (R) Virtualization Technology" e "Intel (R) Vt-d Feature" do BIOS. Depois que as opções apareceram, não há necessidade de reinstalar o VirtualBox. - eis
O que é VT-x/AMD-v cpus? Onde posso encontrá-lo? - AlikElzin-kilaka
Se esta resposta disse para permitir a visualização no BIOS, que funcionou para mim. A opção da bios era VTx. - AlikElzin-kilaka


Como a configuração do VT-x normalmente é travada na inicialização, é necessário desligar completamente o sistema após alterar as opções do VT-x no firmware (BIOS / EFI). Uma simples reinicialização não é suficiente!

Pode estar relacionado apenas para processadores Intel


4





Eu tive uma questão semelhante. Post VT-x na sua BIOS e reinicie, você pode tentar reinstalar o VirtualBox? Por algum motivo, a opção de 64 bits não aparece, a menos que você reinstale o VirtualBox. Eu fiz isso e resolvi o problema para mim.


3



nenhum resultado com a reinstalação depois de desativar o Hyper-V - Xitcod13


Eu tive o mesmo problema; O Hyper-V desinstalado, a virtualização BIOS / UEFI ativada, tentou forçar a VM a ser ativada.

No final, a solução foi bem simples:

Quando você instalar o VirtualBox com todas as configurações corretas, ele indicará que apenas 32 bits convidados estão disponíveis como antes. No entanto, se você, em seguida, reiniciar o computador e tentar carregar o VirtualBox novamente (para mim, ele caiu duas vezes antes de carregar com êxito), as opções de 64 bits aparecem do nada.


1





A solução para mim foi atualizar minhas biografias. Mesmo que a minha bios de 2012 tivesse a opção de virtualização da Intel, não funcionou para mim. Eu estou supondo que foi uma incompatibilidade entre os meus bios e meus drivers do Windows. Piscar para a bios de 2014 corrigiu o problema para mim. Agora eu tenho todas as opções de x64 na minha caixa virtual.


0



Isso realmente não é uma resposta à pergunta do autor - Ramhound
É uma solução em potencial para qualquer um que tenha o problema de vt-x não funcionar e, como resultado, não ter opções x64. Então obrigada pelo ódio do @ramhound. - Rafe
Não é pessoal. Sua pergunta estava na revisão por causa da baixa qualidade. - Ramhound


Eu não tinha percebido que as etapas para acessar o BIOS haviam mudado no Windows 8.1, mas esse é o link mais útil para esse problema !: http://www.makeuseof.com/tag/how-to-access-the-bios-on-a-windows-8-computer/

Depois de entrar no BIOS, seguindo os passos do link acima, ative o "SVM" e você deve estar pronto!


0



Como essa resposta se aplica à pergunta? - Wes Sayeed


Depois de seguir os passos que a maioria dos outros recomendou, ainda não consegui seguir em frente; o que foi para mim foi desabilitar antivírus (no meu caso Avast). Virtualbox reiniciado e voila!


0