Questão Como evitar que o Windows 10 desperte do sono ao viajar em bolsa?


Eu não estou desligando o laptop, mas sim colocando em hibernação, pois ele começa muito mais rápido e posso continuar trabalhando sem iniciar todos os aplicativos novamente.

Ele estava trabalhando muito tempo do Windows XP para o Windows 8.1.

No entanto agora (após a atualização para o Windows 10), quando eu tirei o meu laptop da bolsa depois de uma viagem, estava muito quente. Eu percebi que está ligado.

No log de eventos, descobri que estava instalando atualizações e, antes disso, havia o seguinte log:

O sistema retornou de um estado de baixa energia.

Tempo de sono: 2015 - 08 - 16T12: 55: 18.180075900Z Tempo de despertar:   2015 - 08 - 16T12: 55: 17.852758500Z

Wake Source: Desconhecido, mas possivelmente devido ao temporizador - o Windows irá   executar 'NT TASK \ Microsoft \ Windows \ UpdateOrchestrator \ Reboot'   tarefa agendada que solicitou o despertar do computador.

Quando localizei a tarefa acima no agendador de tarefas, ela disparou nesse momento, no entanto, o "último tempo de execução" é o dia anterior. Então eu não sei em que acreditar "o último tempo de execução" ou a origem do evento acima?

Como descobrir o que está despertando o computador da hibernação (é possível?) E como evitá-lo?


85


origem


Eu encontrei uma página que obriga o Windows a não alterar a reinicialização superuser.com/questions/973009/…


Respostas:


Isso funcionou para mim até agora. Vamos para:

Painel de Controle \ Hardware e Sons \ Opções de Energia \ Editar Configurações do Plano

Clique em "Alterar configurações avançadas de energia"

Vá para "Sleep-> Allow wake timer" e mude a configuração para Disable.

power options screenshot 1

ATUALIZAR: Como Erik apontou, pode haver duas opções:

power options screenshot 2 with 2 options

Desative os dois.


66



Não funcionou para mim, que já estava desativado, e a atualização do Windows acordou meu PC de qualquer maneira - Erik
Use "powercfg -waketimers" para verificar a presença de quaisquer outros temporizadores de ativação. Algumas versões do Spotify e do TeamViewer também relatam a criação de temporizadores de despertar. No entanto, eu também tenho problema do Windows 10 ignorando timers de desperto desativado. - voldemarz
Para qualquer um que esteja lendo isso, o Spotify consertou o bug que fazia com que ele criasse temporizadores de despertar algumas semanas atrás. - Godsmith
@ Dan: Obrigado, mas eu prefiro não reorganizar minha vida em torno da incompetência da MS. ; -) - Nick Westgate
@ Dan: Estou longe do meu computador por alguns dias e às vezes preciso acessar meu computador remotamente. Se estiver em estado de suspensão, posso enviar um pacote WOL para ativá-lo e colocá-lo em suspensão quando terminar. No entanto, não quero que ele acorde com o Windows Update e perca energia por dias. - user33339


No WIN 10, há uma opção no Editor de Diretiva de Grupo Local para configurá-lo facilmente:

  1. Pesquisa:  Local Group Policy Editor (você pode lançar gpedit.msc)
  2. Navegar para:  Computer Configuration / Administrative Templates / Windows Components / Windows Update
  3. Clique duas vezes em:  Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates e defina como "Desativado".

Figura para configuração do Editor de Diretiva de Grupo Local:

enter image description here


56



OMI esta é a solução correta. Desativar completamente os temporizadores de despertar nem sempre é desejado. - JeffRSon
+1, mas não quero que acorde (à noite) por qualquer motivo! Há uma nova configuração para Permitir temporizadores de despertar: Somente temporizadores importantes. Não faço ideia do que faz. Espero que a própria MS acorde e nos permita especificar o intervalo de tempo durante o qual os despertares são permitidos. Ah, e os usuários do Windows 10 Home não têm gpedit mas aparentemente pode usar um hack de registro. - Nick Westgate
Desativei a política, mas a tarefa do Windows ainda estava registrada (marcada com "powercfg-waketimers"). Tive que ir e desativar manualmente a tarefa do Windows, conforme superuser.com/a/958264/267379 para fazê-lo funcionar. Espero que a combinação de dois funcione: D - Sean Feldman
Não posso confirmar que esta política funciona. Eu já tinha definido esta política para desativado desde semanas, e ontem à noite a tarefa "UpdateOrchestrator \ Reboot" acordou o computador do sono. - Thorsten Albrecht
@ThorstenAlbrecht Mesmos aqui. Estou executando o Windows 10 Pro v1703 de 64 bits (Build 15063.540) e o UpdateOrchestrator\Reboot  tarefa agendada foi retomada da hibernação esta manhã, embora eu tenha esta política definida para Disabled. Na verdade, estou surpreso que minhas configurações de Política de Grupo Local não tenham sido atingidas pela Atualização do Criador, como quase todo o resto fazia. No mínimo, tentarei desabilitar e redefinir essa política e ver se isso tem algum efeito. - BACON


Após a atualização para o Windows 10, o computador no meu quarto continuou me acordando às 3 da manhã. Desativando Wake the computer no Microsoft\Windows\UpdateOrchestrator\Reboot tarefa agendada não ajudou. O Windows ativa a bandeira de volta periodicamente. Mesmo a desativação de "Desativar temporizadores de ativação" em Opções de energia não ajudou. O UpdateOrchestrator continuava orquestrando os alarmes da meia-noite.

Como solução, adicionei um script powershell que remove as configurações de ativação a cada hora.

  1. Para permitir a execução de scripts do PowerShell: execute o PowerShell como administrador e execute:

    Set-ExecutionPolicy RemoteSigned

  2. Crie um arquivo chamado "disable_wakejobs.ps1" que contenha uma linha de código:

    Get-ScheduledTask | ? {$_.Settings.WakeToRun -eq $true -and $_.State -ne "Disabled"} | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_}

  3. Abra o Agendador de Tarefas e crie uma tarefa agendada.

  4. Na guia "Geral", defina a conta do usuário como usuário "SISTEMA" (ou você terá que atualizar uma senha salva toda vez que alterar sua própria senha.)
  5. Na guia "Acionadores", crie um acionador que execute o trabalho diariamente e repita a cada hora.
  6. Na guia "Ações", crie uma ação para "Iniciar um programa", com "Programa / script" definido como "PowerShell.exe" e argumentos -Command "c:\tools\disable_wakejobs.ps1" (mude o caminho para onde você armazenou disable_wakejobs.ps1 no passo 2.)

Os comandos do PowerShell vêm de este post de Reidar Johansen.


30



Eu recebo um erro executando isso: Set-ScheduledTask: O parâmetro está incorreto. Em C: \ Usuários \ Filip \ scripts \ disable_wakejobs.ps1: 1 char: 123 + ... Desativado "} |% {$ _. Settings.WakeToRun = $ false; Set-ScheduledTask $ _} + ~~~~~ ~~~~~~~~~~~~~~~ + CategoryInfo: InvalidArgument: (PS_ScheduledTask: Raiz / Microsoft / ... S_ScheduledTask) [Set-ScheduledTask], CimException + FullyQualifiedErrorId: HRESULT 0x80070057, Set-ScheduledTask - Godsmith
Nenhuma das outras soluções funcionou para mim, então estou esperando que isso funcione! Hacky, mas o que eu puder fazer para não ligar o meu PC no meio da noite, eu vou fazer. - GotDibbs
Quão louco é isso? Você não pode mais confiar nas configurações e elas foram redefinidas. A Microsoft está fora de si? É totalmente não confiável. - t3chb0t
Não vejo como configurar a conta de usuário para o usuário "SYSTEM" na etapa 4. - Castaa
@ Casta-bit mais tarde, mas você pode alterá-lo selecionando Alterar usuário ou grupo e digitando System e depois pressione check name. O resultado final deve ser assim: puu.sh/mOIX4/58082e816e.png - Paul


Isso deve resolver seu problema:

  1. Pesquisa Task Scheduler
  2. Navegar para Task Scheduler Library\Microsoft\Windows\UpdateOrchestrator\Reboot
    Nota:  Reboot é apenas um arquivo, mas você precisa ir dentro de todas essas pastas
  3. Clique direito Propriedades então clique Condições
  4. Desmarque Wake the computer to run this task

6



Eu mudei isso, espero que não seja executado novamente. - TN.
Esta não é a solução; O Windows irá reativar a caixa de seleção novamente na próxima vez :-( - kipusoep
Eu fiz isso, mas o Windows ativou a bandeira novamente. O Windows até ignora a configuração "Disable wake timers". Aqui está um postagem no blog que mostra como desmarcar o "Acordar o computador" de uma tarefa agendada. - Andomar
Sim, a caixa de seleção está ativada novamente ... - TN.
Não só isso WIndows redefine essa opção, ele ainda não consegue inseri-lo como uma razão para que o usuário sabe por que o computador reiniciado: Quando eu pergunto powercfg pela razão, ele diz "desconhecido" :( isso é ruim por design e Microsoft deve corrigir isso o mais rápido possível, me levou horas para realmente descobrir o que ficava acordando meu sistema.Além disso, a reinicialização foi totalmente desnecessária, porque eu já fiz isso logo após a atualização, mas a Microsoft decidiu reiniciar de qualquer maneira :( - Erik


Estou usando o recurso Wake On LAN (WOL) no meu computador para que eu possa acordar meu computador remotamente se eu precisar acessá-lo enquanto estiver ausente .. para que o WOL funcione é que preciso permitir que minha placa de rede acorde o computador quando eu enviar o pacote mágico WOL.

Isso de alguma forma está fazendo com que meu computador acorde aleatoriamente sem motivo aparente. Para saber se isso está fazendo com que seu computador acorde aleatoriamente, digite este comando no prompt de comando:

powercfg -lastwake

enter image description here

Se você ver algo sobre a sua placa de rede (como o meu Realtek PCIe) .. então você precisa ir para a configuração de propriedades da placa de rede e verifique se o Only allow a magic packet to wake the computer a caixa de seleção está marcada (a minha não foi):

enter image description here

Então ore ao seu Deus ...


4



Este é o único que funcionou para mim: D - Jamie Hutber
Essa é uma boa solução para uma questão diferente. A pergunta identifica "TASK \ Microsoft \ Windows \ UpdateOrchestrator \ Reboot" no Windows 10 como a causa. WOL é difícil de configurar corretamente, então espero que isso ajude os outros também. - user33339


Essa parece ser a tarefa de manutenção do sistema em execução. Nesse caso, você pode tentar desativar a manutenção do sistema.

Controle WIN + R procure por "manutenção" na caixa de pesquisa, selecione "Alterar configurações de manutenção automática".

Desmarque a opção "Permitir manutenção agendada para ativar meu computador no horário agendado".

Veja se isso ajuda a remover o problema. Vai ser muito mais confiável do que alguns dos outros mecanismos propostos.


1



Eu tenho esta caixa de seleção desmarcada. (Então não vai ajudar no meu caso.) - TN.


Aplicando a solução da Andomar, também recebi o erro:

  • Set-ScheduledTask: o parâmetro está incorreto. Em C: \ Users \ Filip \ scripts \ disable_wakejobs.ps1: 1 char: 123 + ... Desativado "} |% {$.Settings.WakeToRun = $ false; Set-ScheduledTask $} + ~~~~~~~~~~~~~~~~~~~~ + CategoryInfo: InvalidArgument: (PS_ScheduledTask: Raiz / Microsoft / ... S_ScheduledTask) [Set-ScheduledTask], CimException + TotalmenteQualificadoErroId: HRESULT 0x80070057, Set-ScheduledTask

No meu caso, isso foi devido a uma tarefa que não pode ser editada (AUSessionConnect no WindowsUpdate para ser preciso). Então eu edito a tarefa responsável diretamente (Reinicie dentro do UpdateOrchestrator). O arquivo disable_wakejobs.ps1 correspondente se parece com isso (para saber como usar esse arquivo, verifique a resposta da Andomar):

Get-ScheduledTask -TaskName "Reboot" | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_}

Para testar o script manualmente, assegure-se de executá-lo a partir de uma instância elevada do PowerShell (Executar como administrador).


1