Questão Como parar o Mac para converter o traço duplo de digitação para o emdash?


Eu acho que é uma coisa do Leão da Montanha, quando você digita - (traço) duas vezes, ele se torna - (emdash). Quando você digita tm, ele se torna (símbolo de marca registrada). Ou quando você digita três. (ponto), torna-se… (elipses). Alguns são úteis, alguns são muito irritantes. No geral, quero parar com isso. Como posso conseguir isso?


89


origem


Apenas uma nota para outras pessoas lendo, que se não é uma coisa de OSX para você, então pode ser o seu editor de texto. Eu tive que mudar o TextEdit com Preferências> Smart traços. - levininja
Pergunto o que é a solução do macOS Sierra. - Charlie Parker
Parece que alguns aplicativos precisam ser fechados e abertos para que as coisas funcionem. Eu estava usando notas app e parece que não funcionou até que eu fechei um aplicativo aberto (completamente sair). Pode ter sido que eu fiz defaults write 'Apple Global Domain' NSAutomaticDashSubstitutionEnabled 0, mas quem sabe. - Charlie Parker


Respostas:


(na Sierra 10.12, isso agora está no painel de controle do teclado)

Vá para as preferências do sistema e escolha "Idioma e texto"

enter image description here

Na aba "Texto", você encontrará a lista de substituições.

enter image description here

Se você quiser parar -- de ser transformado em  (emdash) você precisa usar o + botão e adicione uma nova regra para substituir -- com -- (substitua por si mesmo)

Ou clique com o botão direito em um campo de texto e vá para "Substituições" e desative "Smart Dashes"

Stupid Dashes


92



ah ok, então se eu fizer outra regra como "-" para "-" então ele salva meus traços duplos. Obrigado! - beatak
Adicionando - para ser substituído por si só não parece funcionar em Yosemite (e Keynote) :( - Balint Erdi
@BalintErdi Acabei de encontrar esta pergunta novamente pesquisando sobre o assunto, encontrou a resposta, pensou Hmmm, isso não funciona, que idiota postou esse truque e então viu que era própria maldita edição. RI MUITO. Acabei de atualizar a resposta, espero que funcione melhor agora! - Josh
El Capitan 11.11 Isso agora está no painel de controle do teclado. - vy32
Eu tive que fechar e reabrir o TextEdit para que ele funcionasse no Yosemite. Não é necessário reiniciar. - Kris


Eu encontrei esse mesmo problema no Mavericks (10.9), onde a correção mudou um pouco. Vá para Preferências do Sistema, depois "Idioma e Região", clique no botão "Preferências do Teclado ..." e vá para a aba "Texto". No entanto, não é mais uma substituição, mas no lado direito da janela há uma caixa de seleção "Usar cotações e traços inteligentes". Desmarcar isso impede a troca de dois hífens em um traço.

Uma pequena pegadinha: no 10.9.5 com o TextEdit (e provavelmente outros) você deve sair e reiniciar o editor para que essa mudança tenha efeito.


48



E também desativa as citações inteligentes. Eu não tenho ideia de por que a Apple decidiu colocar esses dois no mesmo balde nas preferências. Felizmente, você pode desativá-los individualmente em Editar> Substituições, embora esse comportamento seja por aplicativo. - dgatwood
Em 10.11 El Capitan, pelo menos, é possível desativar apenas traços inteligentes (mantendo as aspas inteligentes) executando defaults write 'Apple Global Domain' NSAutomaticDashSubstitutionEnabled 0 do terminal. Existem duas configurações separadas sob o capô, NSAutomaticDashSubstitutionEnabled e NSAutomaticQuoteSubstitutionEnabled, ambos são alternados pela caixa de seleção da interface do usuário "Usar aspas e traços inteligentes". Mas não há garantia da Apple de que isso não mudará em versões futuras do OS X. - Adam Rosenfield
muito obrigado @AdamRosenfield, sua solução é de longe a melhor listada aqui. - zanona
@AdamRosenfield, você deve elevar este comentário a uma resposta para que possamos votar nele. :-) - Nick K9
Tem certeza que isso funciona? Preciso reiniciar meu Mac ou reiniciar meus aplicativos? - Charlie Parker


Em 11.11 isso está sob System Preferences > Keyboard. Há uma caixa de seleção para Use smart quotes and dashes.

Teclado pref em 11.11


24



Exceto que isso também desativa as aspas, o que você provavelmente não faça querer fazer. Desativar traços inteligentes em Editar> Substituições corrige o problema de forma mais limpa (desligando apenas os traços), com a ressalva de que o comportamento é por aplicativo. (Por quê!?!) - dgatwood
Por que você quer citações inteligentes? Eu sempre considerei uma solução para um problema que nunca existiu. Eles também são especialmente horríveis para programadores. - CoreDumpError
Tem certeza que isso funciona? Preciso reiniciar meu Mac ou reiniciar meus aplicativos? - Charlie Parker
@dgatwood Portanto, nem todos os aplicativos suportam Edit> Substitions. No Slack, por exemplo, não vejo outra solução senão desativar ambas, como essa resposta sugere. +1 para esta resposta (embora eu não me importe com as citações inteligentes se for digitá-las) - Mark Edington


Nas versões anteriores do Mac OS X, havia duas opções separadas para aspas inteligentes e traços inteligentes nas Preferências do Sistema do Teclado; no entanto, pelo menos nas versões 10.9 a 10.11, essa opção foi substituída por uma única preferência "Usar aspas e travessões inteligentes".

Felizmente, ainda existem duas preferências separadas sob o capô ea caixa de seleção da interface com o usuário alterna as duas simultaneamente. Você pode ativar ou desativar apenas uma das citações inteligentes ou traços inteligentes do terminal:

# Disable just smart dashes
defaults write -g NSAutomaticDashSubstitutionEnabled 0

# Disable just smart quotes
defaults write -g NSAutomaticQuoteSubstitutionEnabled 0

# To re-enable, set either back to 1.

Isso é verdade atualmente no OS X 10.11; isso pode mudar em futuras versões do OS X (ou macOS, como agora será chamado).


15



Ainda funciona a partir de 10.12.6 - obrigado! - Glenn
Ainda funciona no 10.13 também. - ShiDoiSi


Não tenho certeza se vocês ainda estão tendo esse problema, mas acabei de descobrir como isso pode ser frustrante. Eu estava escrevendo um script unix para o Apple Remote Desktop, que requer um --get flag e continuou sendo convertido em um traço, arruinando o comando.

Eu não consegui encontrar uma maneira de desligar a conversão em traço, mas toda a esperança não está perdida. No menu Idioma e texto (guia Texto), criei uma entrada que substitui -- com -- (isto é, ele substitui dois traços por si mesmo). Isso substitui o sistema de conversão -- para um traço.


4





Vale ressaltar que, mesmo com "use aspas e traços inteligentes" ativados, você ainda pode "desfazer" a conversão automática de - para - (emdash) pressionando CMD + Z. Se desligar corretamente os traços inteligentes soa muito extremo, esta é uma maneira de trazer de volta o - (traço duplo).

Além disso, aqui está a minha história de horror sobre "aspas encaracoladas:" eu estava usando Github por anos e me perguntei por que minhas "contribuições" nunca apareceram corretamente no meu perfil. Eu finalmente descobri que tinha configurado meu nome de usuário git no terminal com aspas curvas em vez de marcas retas:

git config --global user.name “Steve”       //instead of...
git config --global user.name "Steve"

Mesmo que eu estivesse copiando / colando o comando diretamente de Instruções do GitHub, TextEdit estava "consertando" minhas citações antes de colocá-las no Terminal. Inacreditável! Isso me deixou louco, mas estou me recuperando ...


2





No uso das ferramentas "Office" da Apple: Página, Número, etc., as configurações em Preferências do Sistema ou o comando de padrões da linha de comando, como mencionado nas respostas anteriores, não afetarão as substituições inteligentes. Em vez disso, você terá que ir para a barra de ferramentas superior Editar> menu Substituições para marcar ou desmarcar "Smart Quotes", "Smart Dashes" etc.

Se você estiver usando o TextEdit, a resposta do 7stud é o caminho, que está incluído aqui para ser completo: TextEdit> Preferências e marque / desmarque as configurações nas seções inferiores.


1





Esse comportamento é controlado por um padrão do sistema. Para desligá-lo, digite no terminal:

    padrões escrevem -app 'Keynote' TSWPAutomaticDashSubstitution 0

ou

    padrões escrevem 'Apple Global Domain' TSWPAutomaticDashSubstitution 0

O primeiro desliga a substituição do painel para um aplicativo em particular (aqui, Keynote); o segundo para todos os aplicativos que não têm seus próprios, substituindo, padrão definido explicitamente. Substituir 0 de 1 para ativar a substituição do traço.

Como outras respostas aqui afirmaram, o padrão global também pode ser alterado usando Preferências do Sistema (Teclado> Texto> Caixa de seleção "Usar aspas e traços inteligentes"), mas isso liga e desliga citar substituição assim como substituição de traço. Além disso, alguns aplicativos, mas não todos, permitem que você altere seus padrões clicando com o controle em um campo de texto e selecionando Substituições ou Mostrar substituições. Por exemplo, Enviar deixa você fazer isso, mas Keynote não.

Se você quiser ativar a substituição de cotação, por exemplo, Keynote usar

padrões escrevem -app 'Keynote' NSAutomaticQuoteSubstitutionEnabled 1

ou, para ativá-lo para tudo o que não tem um padrão de substituição, use

padrões escrevem 'Apple Global Domain' NSAutomaticQuoteSubstitutionEnabled 1

Para desligá-lo, use 0 ao invés de 1.


1



Para Slack, onde isso estava me deixando louco, acho que a chave de configuração é WebAutomaticDashSubstitutionEnabled. - Michael


Se você quiser evitar que isso aconteça de vez em quando, ou por algum exemplo específico, você pode simplesmente esperar que o Mac faça a alteração indesejada e pressione CMD+z desfazer.


1



Você testou isso com o "-" e "-" para confirmar que isso funciona conforme o esperado, conforme descrito pelo OP? - Pimp Juice IT


Yosemite 10.2 and TextEdit:

  1. Inicie o TextEdit.

  2. TextEdit> Preferências

  3. No canto inferior direito, desmarque Smart dashes .

  4. Se o seu arquivo TextEdit estiver aberto, feche-o e reabra-o.


0