Questão SO guest do VirtualBox acessando o servidor local no sistema operacional host


No meu host Ubuntu eu tenho meu servidor web local. Eu instalei o VirtualBox e o Debian como convidado.

Eu gostaria que o convidado Debian conseguisse acessar meu servidor web rodando no meu host Ubuntu (por exemplo, eu apenas digite http://localhost:8080/ no navegador no Debian).

Como isso pode ser feito?


93


origem




Respostas:


Ative UM adaptador de rede. Defina-o como NAT e inicie sua máquina. Não precisa configurar nada.

No tipo de navegador da máquina convidada http://10.0.2.2 que mostrará o mesmo conteúdo que "localhost" no sistema operacional host.

10.0.2.2 é o "gateway padrão" para conexões NAT e o IP do sistema operacional convidado é 10.0.2.15

Claro que você pode definir um "HOST-ONLY" ou uma "rede interna", que lhe permitirá outras configurações avançadas. Eu recomendo ficar com o NAT.

Apreciar

M.


153



Ok, obrigada! Funcionou! Muito obrigado! Essa foi a maneira mais fácil para mim, como eu sou novato e não pode efetivamente captar soluções mais avançadas. - Maxim
Obrigado por esta resposta. Isso me tirou uma ligação semelhante. - kingkool68
"Ativar UM adaptador de rede". Onde isso é feito? - jshen
Nota: Se você tiver hosts virtuais baseados em nome configurados no apache em sua máquina host, você poderá acessá-los simplesmente criando um mapeamento no arquivo hosts hosts da máquina para 10.0.2.2 yourvirtualhostname.local (or whatever) - User
@ ТомицаКораћ ele funciona. Por exemplo, veja: askubuntu.com/questions/36183/… no entanto, você provavelmente deve abrir uma pergunta separada para resolver isso. - User


Além disso, um ponto a ser feito ao usar o endereço IP de 10.0.2.2 é se você estiver usando o MAMP, por exemplo, adicione o número da porta: 8888 para que o endereço completo seja lido. http://10.0.2.2:8888


5





A maneira mais fácil de permitir acesso ininterrupto à sua máquina VirtualBox Guest é configurar o dispositivo de rede como uma 'ponte' para a sua eth0 na sua LAN.

A máquina convidada irá pegar um IP da LAN via DHCP do seu roteador.


3



Para esclarecer: esta é uma configuração no aplicativo cliente. Funcionou para mim - só demorei um pouco para perceber, porque o IE era burro demais para assumir que eu queria uma conexão HTTP quando digitei um endereço IP e uma porta na barra de endereços. - Michael Scheper


O que eu encontrei corrigiu o problema para mim estava certificando-se de que o adaptador VirtualHost-Only do Windows foi definido para o endereço .1 para o intervalo de ip para meu adaptador de host de caixa virtual só foi 192.168.58.20 mas o ip para o adaptador do Windows é 192.168. 58,1


2





Se a solução por @Melvyn não funcionar, como alternativa, você pode configurar o adaptador de rede para ser ligado em ponte.
Vamos para Settings -> Network -> depois mude Attached to para adaptador em ponte.

enter image description here

Você deve ser capaz de chamar pai pelo seu nome de host ou endereço IP externo, você pode obtê-lo indo ao prompt de comando e digitando ipconfig /all enter image description here

enter image description here

Atualizar Se você estiver depurando com o Visual Studio e usando o IIS Express.

vamos para C:\Users\[uesername]\Documents\IISExpress\config\applicationhost.config

encontre seu site em <configuration>/<system.applicationHost>/<sites>/<site>  (nome pode ser enganoso tente verificar a localização no disco em physicalPath atributo)

em seguida, adicione <bindings> seção nova ligação

<bindings>
    <binding protocol="http" bindingInformation="*:50766:localhost" />
    <binding protocol="http" bindingInformation="*:50766:48qzr12" />
</bindings>

onde bindingInformation é *:[port]:[machineName]

Espero que isso economize algum tempo.


2





Bem, você pode fazer o Debian acertar seu servidor, mas não usando localhost. Você terá que usar o endereço IP do host do Ubuntu.

Assumindo que o sistema operacional convidado esteja conectado à rede, para pegar o IP, abra um terminal e digite ifconfig. Deve parecer algo como 192.168.0.2.


0



Oi! Desculpe pela resposta tarde demais. ifconfig no meu host mostra 192.168.0.102 para eth0. Quando eu entro este ip no firefox em guest ele está tentando se conectar por um tempo e então a conexão é finalizada: "O servidor em 192.168.0.102 está demorando muito para responder" ... Então o que devo tentar em seguida? Desde já, obrigado. - Maxim