Questão Eu acidentalmente clicou em "ignorar" quando o Chrome perguntou se eu queria usar um manipulador de protocolo. Como faço para "ignorar" isso?


Eu acidentalmente ignorei o gd.pool manipulador de protocolo no Gamedesire.com quando o Google Chrome me pediu para escolher o aplicativo padrão para este tipo de link, e não consigo descobrir como fazê-lo me perguntar novamente.

Como posso reatribuir esse manipulador de protocolo ou fazer o Chrome me avisar novamente?


4


origem




Respostas:


De acordo com Documentação do Chrome sobre manipuladores de protocolo, você pode alterar os manipuladores padrão na caixa de diálogo Gerenciar Manipuladores:

  1. Clique no botão Menu do Crome
  2. Selecione Configurações> Mostrar configurações avançadas
  3. Clique Configurações de conteúdo dentro de Privacidade seção
  4. Encontre o Manipuladores seção
  5. Clique Gerenciar manipuladores

Você pode adicionar, remover e atualizar manipuladores de protocolo aqui. Além disso, você pode clicar com o botão direito do mouse em um link e selecionar ** Abrir link com ... * para escolher um manipulador único a ser usado sem alterar o padrão.


1



Essa resposta parece datada. Gerenciar manipuladores não mostra que estou ignorando um protocolo e não vejo "Abrir link com ..." quando clico com o botão direito no link no Chrome 39. - Corey Ogburn
@CoreyOgburn Parece atualizado comigo. Você pode fornecer um exemplo mais específico onde isso não está funcionando? Qual protocolo você deseja que um site lide e qual site você está visitando que deseja lidar com ele? - Darth Android
Magnético. Pode não ser que não esteja atualizado, pode ser apenas que isso não listará os manipuladores de protocolo para programas externos. - Corey Ogburn
Não, acho que não. Acho que isso é para se um website (por exemplo, GMail) quiser manipular links de outros programas em seu computador (por exemplo, todos mailto links). Modificar as coisas lá faz com que o Windows no meu sistema apareça e pergunte se quero que o chrome manipule esse protocolo. - Darth Android


O Google estupidamente prejudicou a interface do usuário de preferências para que você não possa editar os manipuladores de protocolo por mais tempo que você estabeleceu respondendo a pequena caixa de diálogo (captura de tela) com "Sempre aberto ...". O que fiz para resolver o meu problema (assumindo o perfil "Predefinido" do Chrome):

Finalizar o Chrome Em seguida, edite este arquivo de texto: 

C:\Users\USERNAME\AppData\Local\Google\Chrome\User Data\Default\Preferences

É tudo em uma linha, não para edição humana. Se o seu editor (por exemplo, Notepad ++) apresenta destaque de idioma, escolha JSON.

Tive que mudar o texto
"protocol_handler":{"excluded_schemes":{"mql4buy":false}},
para
"protocol_handler":{"excluded_schemes":{}},
então eu acabei de remover
"mql4buy":false

Isso foi para o link de protocolo personalizado mql4buy://(etc)

Como seu problema é que seu protocolo é ignorado, talvez você tenha uma entrada para o seu protocolo dizendo ": true".


0