Questão Só pode ssh quando não estiver usando wi-fi


Então, eu tenho 3 máquinas, uma área de trabalho do Windows 7 que está sempre conectada ao meu roteador, laptop OSX e raspberry pi executando o Debian Linux. Meu roteador é um Linksys e1000 sem fio N.

Meu objetivo é ser capaz de ssh o raspi de qualquer máquina, enquanto ele está conectado via wifi. Meu problema é que ao tentar ssh do win7 ou do osX para o Pi ele chega ao tempo limite, ou dá um erro: "ssh: connect to host 192.168.1. ### porta 22: Nenhuma rota para hospedar"

As únicas vezes que consegui me conectar ao pi de qualquer máquina foram quando ele se conectou ao roteador através de um cabo Ethernet.

Atualmente, com testes de desktop com fio win7, macbook wireless e pi sem fio, o seguinte:

win7 ping macbook: host de destino inacessível. macbook ping win7: Tempo limite do pedido. win7 ping pi: host de destino inacessível. macbook ping pi: Tempo limite do pedido. blá blá blá

Conectando o macbook no roteador com um cabo Ethernet toda a comunicação entre win7 e macbook funciona. Pings, ssh, ftp, smb ect ...

Nenhuma alteração no pi, ainda não há conexões possíveis para ou de qualquer uma das outras duas máquinas.

Nota Todas as máquinas, são capazes de se conectar à internet e ssh para a mesma máquina em uma rede completamente diferente, com ou sem fio.

Conectando o Pi com Ethernet (e o macbook ainda conectado) Eu posso ssh para o pi de win7 e macbook. Eu posso ssh do pi para macbook. Todas as máquinas ainda conseguem conectar a máquina fora da rede.

Outra pequena nota lateral - eu estava jogando warcraft 3 com meus companheiros de quarto no outro dia, e a única vez que eles conseguiram ver meu jogo de LAN foi quando eles foram conectados ao roteador com um cabo Ethernet. Uma ou duas vezes, um dos laptops conseguiu se conectar via wifi, mas não sem outro computador conectando primeiro via Ethernet.

Então, basicamente, alguém tem alguma informação sobre o motivo pelo qual meu roteador parece ignorar completamente o tráfego sem fio local?


4


origem


Correndo o risco de fazer uma pergunta idiota: você tem certeza de que seus dispositivos sem fio estão usando seu roteador sem fio? É possível que eles tenham descoberto outro no prédio ao lado (ou o que for)? Você pode tentar ver suas tabelas de roteamento? (netstat –r deve funcionar no OS X.) - Scott
Sim, tenho certeza. Eu verifiquei a sugestão de isolamento de AP do Calin através do meu laptop, e tive que editar manualmente um arquivo de configuração para o meu pi para se conectar ao meu roteador quando ele é inicializado. Acabei de chegar em casa do trabalho e vou editar meu post original com todas as informações de rede de máquinas individuais amanhã - AChrapko
Qual é o status dessa pergunta? - Mast


Respostas:


Sim. É chamado isolamento de AP. Isso faz com que os dispositivos sem fio conectados ao roteador possam se conectar à Internet, mas não uns aos outros.

Faça o login no seu roteador e desligue o isolamento do AP.

Para o meu Linksys está em Wireless -> Advanced wireless settings -> Ap Isolation (Marque isto para Desabilitar)


3



Obrigado pela resposta. Infelizmente quando fui fazer isso, o meu já estava desabilitado por padrão :( - AChrapko
você pode postar algumas informações da sua rede? - Calin
"ipconfig / all", "netstat -r" como sugerido por Scott, para windows e "ifconfig" e "ip route" ou "route" no linux / os x (primeiro de lan, depois de wireless) - Calin
Isso vai ser muito complicado, e peço desculpas. Vou editar meu post original e acrescentar essa informação. - AChrapko
Desculpe o atraso. Parecia horrível copiar / colar a saída, então eu a vinculei no espaço da minha universidade - AChrapko


Se o seu já estiver desativado por padrão, tente:

Com o Cisco E3000, ative o AP e salve as configurações, desative o AP e salve as configurações novamente.

Você deve então poder conectar o SSH ao meu RPi sem fio a partir de qualquer computador conectado a uma rede doméstica.


-1