Questão Como posso configurar o GIMP 2.8 para ser uma única janela no XMonad?


Estou tentando fazer com que o GIMP seja exibido como uma única janela no XMonad. Atualmente, ele está flutuando estranhamente na frente de todos os outros monitores e eu não posso usá-lo.

Eu tentei ler isto:

http://www.haskell.org/haskellwiki/Xmonad/General_xmonad.hs_config_tips#Gimp

Mas parece que isso é para versões do GIMP antes de 2,8 quando não havia a opção de ter o GIMP usando apenas 1 janela. Por causa disso, é um problema do XMonad, não um do GIMP.

Como posso fazer isso?


4


origem


Qual é a sua versão Xmonad? - ItsNotAboutTheName
@Nima versão 0.10-4 - Pubby
Ok, você pode fornecer seu xmonad.hs? - ItsNotAboutTheName
@Nima A única coisa que eu mudei nela são atalhos diferentes, caso contrário é o padrão. - Pubby
Eu gostaria que o GIMP / Steam / Evince parasse de tentar gerenciar mal as janelas e deixasse o gerenciador de janelas fazer o seu trabalho! - Mark K Cowan


Respostas:


O Gimp 2.8 possui uma opção no menu "Windows", intitulado "Modo de Janela Única". Verifique isso e reinicie o Gimp.

pic of option in gimp


10



Talvez um grito ... Essa opção não ajuda com o Xmonad? Vá em frente, me chame ... {sigh} - lornix
Eu tenho essa opção marcada, mas o XMonad está tratando isso de forma estranha e flutuando na frente de todo o resto. - Pubby
@Pubby: Tente encaixar as janelas flutuantes nos lados direito e esquerdo da janela central. - harrymc


Vou tentar de novo.

Como despir o Gimp

O link tem um pouco de informação sobre o uso do Xmonad. Várias referências a esta página.

Mais uma, especificamente sobre o Gimp:

veja nas respostas abaixo a parte principal do artigo

A parte relevante:

Mas o xmonad também flutua todas as janelas do gimp por padrão. Eu uso isso para evitar a flutuação das duas principais janelas:

managehook = composeall [
    gimp "toolbox" --> (ask >>= doF . W.sink),
    gimp "image-window" --> (ask >>= doF . W.sink),
    manageHook defaultConfig
]
where gimp win = (className =? “Gimp” (fmap (win `isSuffixOf`) role))
role = stringProperty “WM_WINDOW_ROLE”

0



Acho que vou desistir agora enquanto estiver na frente ... Acabei de postar o MESMO link ... {Suspiro} Sinto muito ter te incomodado .. Alguma chance de algum amor pelo segundo link ? - lornix


OK, eu tive o mesmo problema e descobri a melhor solução (pelo menos para mim), enquanto eu estava procurando on-line para um: Basta ir ao modo janela -> janela única. Em seguida, faça a janela ir para tela cheia com mod + t (essa é a ligação padrão).

Eu sei que a primeira parte já foi respondida, mas essa parte só recebe todas as janelas do gimp juntas em uma, ainda é uma janela flutuante, e eu não gosto disso no meu xmonad.


0