Questão Tentando executar o Apache, mas o VMWare Workstation está bloqueando a porta 80


Quando eu executo o servidor Apache, ele mostra que a porta 80 está ocupada porque o WMware Workstation está bloqueando isso. Como posso executar o Apache?


4


origem


Qual versão do VMware Workstation? Em qual sistema operacional você está executando a estação de trabalho VMware? - George M
Você está tentando executar o servidor Apache no host ou na máquina virtual? Você está usando NAT ou rede em ponte para a máquina virtual? - erikxiv
@uther versão 8.0 executando o Ubuntu - shiva
@erikxiv estou executando o servidor apache no host e sim usando NAT para a máquina virtual - shiva


Respostas:


De um VMWare Artigo da base de conhecimento

Conectando-se a máquinas virtuais compartilhadas

A conexão com o VMware Workstation Server (as máquinas virtuais compartilhadas) é administrada pelo serviço do VMware Host Agent. O serviço usa as portas TCP 80 e 443. Esse serviço também é usado por outros produtos VMware, incluindo o VMware Server e o vSphere, e fornece recursos adicionais.

Configurando máquinas virtuais compartilhadas

Com as preferências da Estação de Trabalho de VMs Compartilhadas, você pode desativar / ativar o servidor, designar uma porta diferente para conexão e alterar o diretório de VMs Compartilhadas.

Para acessar as preferências da Estação de Trabalho de VMs Compartilhadas:

  • Vá para Edit> Preferences.
  • Clique na guia VMs compartilhadas.

9



Essas devem ser as respostas aceitas. Me ajuda! - swdev


O VMWAare geralmente bloqueia a porta 443 para compartilhamento entre sistemas remotos. Isso poderia bloquear o apache no xampp. Para resolver isso,

VMWare aberto Vá para Edit> Preferences. Clique nas VMs compartilhadas.

DISABLE SHARING e isso significaria que a porta 443 está fechada para acesso pelo VMWare e seu apache no Xampp funcionará bem!


2