Questão Não é possível instalar o matplotlib no cygwin (problema no freetype)


Seria muito bom ter o matplotlib no meu ambiente cygwin. Eu tenho o Windows 8 de 64 bits com o cygwin de 64 bits.

Quando eu digito:

pip install matplotlib

Eu recebo a seguinte mensagem de erro:

 * The following required packages can not be built:
 * freetype

Como por apt-cyg tenho os seguintes pacotes já instalados:

Searching for installed packages matching freetype: 
cygwin32-freetype2
freetype2-debuginfo
libfreetype-devel
libfreetype-doc
libfreetype6

O que mais precisa? Como instalar o freetype & matplotlib corretamente?


4


origem




Respostas:


Eu tive o mesmo problema no Windows 7 de 64 bits; Eu resolvi isso instalando os pacotes do Cygwin pkg-config e libX11-devel antes de digitar easy_install matplotlib==1.1.1 (a versão 1.3.1 está tendo erros na minha máquina, daí o 1.1.1).


9



Obrigado pela sugestão, vou tentar. Quanto a mim, eu uso apenas o matplotlib fora do cygwin (instalação normal do Windows). - Alexey Petrenko


Eu também tive o mesmo problema no cygwin Windows 8 de 64 bits. Eu segui o conselho em outra resposta (instale pkg-config e libX11-devel) mas o pacote que finalmente me permitiu instalar o matplotlib foi libfreetype-devel. Então só easy_install matplotlib==1.4.2.


3