Questão Usando o Vagrant, não é possível acessar um host virtual apache do navegador da Web do sistema operacional host


Eu instalei o Ubuntu Server 16.04.1 Xenial Xerus (32 bits) no Virtualbox com o Vagrant em um host Windows 7. Os conteúdos Vagrantfile são

Vagrant.configure("2") do |config|
    config.vm.box = "boxcutter/ubuntu1604-i386"
    config.vm.network "forwarded_port", guest: 80, host: 8080
    config.vm.hostname = "vagrant.templavoilaplus"
    config.vm.network "private_network", ip: "192.168.33.148"
    config.vm.synced_folder "E:/xampp/htdocs/github/templavoilaplus/", "/var/www/templavoilaplus/public_html"
    config.vm.provision "shell", path: "setup_for_ubuntu_box.sh"
end

Quando na corrida vagrant up a exibição é

E:\Virtual Machines\vagrant>vagrant up
==> default: Checking if box 'boxcutter/ubuntu1604-i386' is up to date...
==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 80 (guest) => 8080 (host) (adapter 1)
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Connection reset. Retrying...
==> default: Machine booted and ready!
[default] GuestAdditions seems to be installed (5.1.22) correctly, but not 
runni
ng.
: Inappropriate ioctl for device
==> default: Checking for guest additions in VM...
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Mounting shared folders...
    default: /vagrant => E:/Virtual Machines/vagrant
    default: /var/www/templavoilaplus/public_html => 
E:/xampp/htdocs/github/templavoilaplus
==> default: Machine already provisioned. Run `vagrant provision` or use the 
`--
provision`
==> default: flag to force provisioning. Provisioners marked to run always will
still run.

E:\Virtual Machines\vagrant>

O conteúdo do arquivo de hosts do Windows é

# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost
216.98.48.18 127.0.0.1
216.98.48.53 127.0.0.1
216.98.48.57 127.0.0.1
216.98.48.133 127.0.0.1
216.98.48.134 127.0.0.1

#adaugat 28/5/2017 pentru vhost xampp github
127.0.0.1 localhost
127.0.0.1 github.localhost

#adaugat 2/6/2017 pentru vagrant private network
192.168.33.148 vagrant.templavoilaplus

Eu a máquina virtual forneci os módulos apache2 e php (por shell script) e criei um host virtual, copiando e modificando 000-default.conf para templavoilaplus.conf. O conteúdo do arquivo é

<VirtualHost *:80>
    ServerAdmin alex@google.com
    ServerName vagrant.templavoilaplus
    DocumentRoot /var/www/templavoilaplus/public_html
    ErrorLog ${APACHE_LOG_DIR}/templavoilaplus_error.log
    CustomLog ${APACHE_LOG_DIR}/templavoilaplus_access.log combined
</VirtualHost>

Na pasta public_html é montada uma pasta do host. Eu corri o a2ensite depois disso e recarreguei o apache. O conteúdo do / etc / host é

127.0.0.1    vagrant
127.0.0.1    localhost
127.0.0.1    vagrant
::1    localhost ip6-localhost ip6-loopback
ff02::1    ip6-allnodes
ff02::2    ip6-allrouters

##vagrant-hostmanager-start
192.168.33.148 vagrant.templavoilaplus

##vagrant-hostmanager-end

Se eu abrir um navegador no host e digitar 192.168.33.148, obtenho a Página Padrão do Apache2 Ubuntu (é bem-sucedida) Além disso, se eu pingar no host

ping vagrant.templavoilaplus

o resultado é

Ping statistics for 192.168.33.148:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 2ms, Average = 2ms

Se eu pingar no convidado (por putty)

ping vagrant.templavoilaplus

exibe algo semelhante (192.168.33.148).

O problema é este: se eu digitar na barra de endereços do navegador do host

vagrant.templavoilaplus

Eu recebo uma página em branco (mozilla) ou resultados de busca no google (chrome). A página index.php (após o redirecionamento do host virtual) deve exibir "sucesso".


0


origem




Respostas:


Descobri que o problema era que eu tinha usado o encaminhamento de porta e a rede privada. Eu estou furando com o encaminhamento de porta.


0