Questão Pacote instalado no FreeBSD, ele está funcionando bem, mas não listado em “pkg info” ou “pkg query”?


Eu acabei de usar pkg info para verificar pacotes no meu sistema FreeBSD (em caso de futura reconstrução), e observe que o ffmpeg não está na lista.

Eu sei ffmpeg está instalado e funcionando, porque eu instalei cerca de 2 dias atrás (pkg install ffmpeg do repo padrão do FreeBSD), e porque eu comecei a fazer um grande trabalho em lote do ffmpeg que levará os próximos 3 dias :)

Isso levanta a preocupação de que outros pacotes também não estejam na lista e não sei por quê.

  # ffmpeg -hide_banner

ffmpeg version 4.0 Copyright (c) 2000-2018 the FFmpeg developers
  built with FreeBSD clang version 4.0.0 (tags/RELEASE_400/final 297347) (based on LLVM 4.0.0)
  configuration: --prefix=/usr/local --mandir=/usr/local/man --datadir=/usr/local/share/ffmpeg --pkgconfigdir=/usr/local/libdata/pkgconfig --enable-shared --enable-pic --enable-gpl --enable-postproc --enable-avfilter --enable-avresample --enable-pthreads --cc=cc --disable-alsa --disable-libopencore-amrnb --disable-libopencore-amrwb --disable-libass --disable-libbs2b --disable-libcaca --disable-libcdio --disable-libcelt --disable-chromaprint --disable-libcodec2 --disable-libdc1394 --disable-debug --enable-htmlpages --disable-libdrm --disable-libfdk-aac --disable-libflite --enable-fontconfig --enable-libfreetype --enable-frei0r --disable-libfribidi --disable-libgme --disable-libgsm --enable-iconv --disable-libilbc --disable-libjack --disable-libkvazaar --disable-ladspa --disable-libmp3lame --disable-libbluray --disable-librsvg --disable-libxml2 --disable-lv2 --enable-mmx --disable-libmodplug --disable-libmysofa --disable-openal --disable-opencl --enable-libopencv --disable-opengl --disable-libopenh264 --disable-libopenjpeg --enable-optimizations --enable-libopus --disable-libpulse --enable-runtime-cpudetect --disable-librubberband --disable-sdl2 --disable-libsmbclient --disable-libsnappy --disable-sndio --disable-libsoxr --disable-libspeex --enable-sse --disable-libssh --disable-libtesseract --enable-libtheora --disable-libtwolame --enable-libv4l2 --enable-vaapi --enable-vdpau --disable-libvidstab --enable-libvorbis --disable-libvo-amrwbenc --enable-libvpx --disable-libwavpack --disable-libwebp --enable-libx264 --enable-libx265 --disable-libxcb --enable-libxvid --disable-outdev=xv --disable-libzimg --disable-libzmq --disable-libzvbi --disable-gcrypt --enable-gmp --disable-librtmp --enable-gnutls --disable-openssl --enable-version3 --disable-nonfree --disable-libaom --disable-libsrt
  libavutil      56. 14.100 / 56. 14.100
  libavcodec     58. 18.100 / 58. 18.100
  libavformat    58. 12.100 / 58. 12.100
  libavdevice    58.  3.100 / 58.  3.100
  libavfilter     7. 16.100 /  7. 16.100
  libavresample   4.  0.  0 /  4.  0.  0
  libswscale      5.  1.100 /  5.  1.100
  libswresample   3.  1.100 /  3.  1.100
  libpostproc    55.  1.100 / 55.  1.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

  # ps -awx | grep ffmpeg
92788  2  S+       0:00.00 grep ffmpeg
35883  0  SN+     43:59.92 ffmpeg -analyzeduration 100G -probesize 100G -i /mnt/...
35903  0  SN+     82:43.76 ffmpeg -analyzeduration 100G -probesize 100G -i /mnt/...
35924  0  SN+     52:09.67 ffmpeg -analyzeduration 100G -probesize 100G -i /mnt/...

  # rehash

  # pkg info ffmpeg
pkg: No package(s) matching ffmpeg

  # pkg query -a %n | grep ffmpeg
<nothing>
  #

Alguma idéia do porquê o ffmpeg não está incluído na lista de pacotes?


0


origem


Qual versão do FreeBSD? Qual versão do pkg? Seu banco de dados pkg contém alguma coisa (pkg info)? - Conrad Meyer


Respostas: