Questão O WSL está agora disponível no LTSB?


Conforme documentado aqui e em outros lugares, o subsistema do Windows para Linux está atualmente em beta e, portanto, não está disponível no Branch de Serviços de Longo Prazo do Windows 10. Minha experiência no LTSB é que você pode ativar o recurso WSL, mas o Windows Store não faria o download do distro appx.

Alguns dias atrás eu notei um início de como o MS:

"Existem vários cenários em que você pode não ser capaz (ou não) de instalar distros do WSL Linux através da Windows Store. Especificamente, você pode estar executando O SKU do OS de desktop do Windows Server ou do Long-Term Servicing (LTSB / LTSC) que não suporta o Windows Store ou as políticas de rede corporativa e / ou os administradores não permitem o uso da Windows Store em seu ambiente.

Nestes casos, enquanto a própria WSL estiver disponível, como você faz o download e instala distros do Linux no WSL se não puder acessar a loja? "

https://docs.microsoft.com/pt-br/windows/wsl/install-manual

Isso me levou a pensar que a WSL estaria disponível no LTSB. No entanto, encontro o mesmo erro de "versão não suportada" quando tento instalar o pacote. Também o MS howto doc parece um pouco apressado (links ruins, erros de gramática / ortografia), então eu não sei quanto estoque para colocar nele.


0


origem


WSL, não é mais um recurso de janelas beta, não é há quase um ano - Ramhound
Dependendo da versão ou da diretiva de rede, é possível que as máquinas Windows não consigam acessar a Windows Store. Por exemplo, de acordo com o site da MS, alguns Windows LTSB podem instalar o recurso WSL, mas não podem acessar a Windows Store. - Jaime
@Ramhound Bem, isso não é beta atualmente não é particularmente relevante. Foi beta no momento da última atualização do LTSB. - Hasse1987
@Jaime Não é exatamente a mesma coisa que eu disse (e mesmo URL que eu postei)? - Hasse1987
Provavelmente, o problema ao tentar instalar uma distribuição do Linux veio com a versão do WSL incluída no seu Windows LTSB. A WSL incluída no ano passado não é a mesma usada hoje. Se você precisa do WSL hoje, você pode tentar com versões antigas das distribuições ou alguns instaladores para o linux no WSL, como WSL-Distrolauncher, WSLInstall e LxRunOffline. Uma versão futura do LTSB incluirá versões mais novas do WSL e você poderá executar distribuições atuais então. - Você sabe qual é o número efetivo de versão / compilação do seu Windows LTSB? - Jaime


Respostas: