Questão Disco rígido externo (USB 3.0) desconecta após meia hora quando o robocopy está copiando arquivos grandes


Estou constantemente enfrentando o mesmo problema, que não consigo copiar arquivos de uma unidade interna para uma unidade externa. estou a usar robocopy com este comando

robocopy D:\ F:\ /e /zb /np /copy:DAT /dcopy:T /r:2 /w:5 /mir /log+:C:\Users\SomeUser\Desktop\Logs\copy.log /XD "System Volume Information" "Recycler"

Depois de meia hora, a janela de comando desaparece, assim como o disco rígido do explorador. Alguns arquivos foram copiados, mas a transferência foi interrompida no meio. O visualizador de eventos mostra as seguintes entradas em ordem decrescente:

ID do Evento 140 / Ntfs:
  Die Daten konnten nicht in das Transaçõesprotokoll   verschoben werden. Die Daten sind möglicherweise beschädigt:   ID do volume: "F:", Gerätename: "\ Device \ HarddiskVolume10".   (Zeßlimit des angegebenen E / A-Vorgangs Das Gerações-Zeitüberschreitung)   auf% hs wurde erreicht, bevor der E / A-Vorgang abgeschlossen wurde.)

ID do Evento 140 / Ntfs:
  Die Daten konnten nicht in das Transaçõesprotokoll   verschoben werden. Die Daten sind möglicherweise beschädigt:   ID do volume: "F:", Gerätename: "\ Device \ HarddiskVolume10". (Ein nicht   vorhandenes Gerät wurde angegeben.)

ID do Evento 51 / Disco:
  Bei einem Auslagerungsvorgang wurde ein Fehler   festgestellt. Betroffen ist Gerät \ Device \ Harddisk2 \ DR3.

ID do Evento 153 / Disco:
  Der E / A-Vorgang an der logischen Blockadresse "0x5b0958"   für den Datenträger "2" (Nome DOP: \ Dispositivo \ 0000008d) wurde wiederholt.

ID do evento 129 / UASPStor:
  Ein Zurücksetzen auf Gerät "\ Device \ RaidPort3" wurde   ausgegeben.

Deve-se conseguir obter a tradução correta com base no id do evento.

Checkdisk não mostra nenhum erro

chkdsk F: /f /r

Outras coisas que eu tentei:

  • use outro cabo
  • use outra porta USB 3.0 (tudo diretamente na placa-mãe)
  • reiniciar
  • economia de energia desativada no gerenciador de dispositivos
  • economia de energia desativada para USB em configurações de energia
  • pesquisou "Legacy USB Support" nas configurações da BIOS, mas não encontrou uma
  • desinstalado "Intel (R) USB 3.0 eXtensible-Hostcontroller - 1,0 (Microsoft)" driver

Nada disso funcionou. O engraçado é que essa configuração funcionou em outra configuração semelhante, mas com outro sistema operacional. A mesma placa mãe, os mesmos discos rígidos, o mesmo gabinete externo, ...

Minha aposta é que o driver padrão do Microsoft USB 3.0 está com defeito. Eu evento não pode instalar outro, porque a Intel não suporta o Windows 10 ... Não sei porque uma tarefa tão simples não pode ser mais feita com um sistema operacional moderno.

Relacionado, mas nenhuma solução funcionou para mim. Pesquisando na internet traz tópicos relacionados - principalmente sem solução real.

Qual é o problema que está causando esse problema e como posso resolver isso?

GSmartControl

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x002f   200   200   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0027   188   188   021    Pre-fail  Always       -       9600
  4 Start_Stop_Count        0x0032   100   100   000    Old_age   Always       -       147
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002e   200   200   000    Old_age   Always       -       0
  9 Power_On_Hours          0x0032   099   099   000    Old_age   Always       -       762
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0032   100   253   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       58
192 Power-Off_Retract_Count 0x0032   200   200   000    Old_age   Always       -       17
193 Load_Cycle_Count        0x0032   200   200   000    Old_age   Always       -       587
194 Temperature_Celsius     0x0022   124   116   000    Old_age   Always       -       28
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   100   253   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       36
200 Multi_Zone_Error_Rate   0x0008   100   253   000    Old_age   Offline      -       0

Comparação de bytes

C:\WINDOWS\system32>fsutil fsinfo ntfsinfo d:\ | findstr /I "bytes"
Bytes pro Sektor :                 512
Bytes pro physischem Sektor :      4096
Bytes pro Cluster :                4096
Bytes pro Dateidatensatzsegment :  1024

C:\WINDOWS\system32>fsutil fsinfo ntfsinfo F:\ | findstr /I "bytes"
Bytes pro Sektor :                 512
Bytes pro physischem Sektor :      4096
Bytes pro Cluster :                4096
Bytes pro Dateidatensatzsegment :  1024

Editar

Agora eu usei outro gabinete externo e o backup funcionou! Eu usei o mesmo cabo USB, a mesma porta USB, a mesma placa-mãe, o mesmo sistema operacional / máquina, o mesmo disco rígido. Apenas o recinto era diferente. Para entrar em mais detalhes:

  • Cremax Icy Dock MB080U3S-1SB Blizzard Parece usar o controlador "ASMT 2105 USB Device" e funciona com o driver do Windows.

  • Fantec - MR-35DU3-6G Parece usar o controlador "JMS56x" e não funciona com o driver do Windows. A unidade aparece como SCSI Disk Drive e neste caso é capaz de usar dois discos rígidos ao mesmo tempo. Na minha configuração, apenas um disco rígido foi instalado.

Em primeiro lugar, alguém poderia pensar que o recinto externo é defeituoso, mas não posso acreditar totalmente nisso porque funcionou antes. Também funciona algum tempo e depois falha com o robocopy. Quando eu fiz a varredura do dispositivo com o checkdisk, fiquei online o tempo todo. Então eu ainda acredito que isso é um problema de driver ou de gerenciamento de energia. Eu não tive esse problema antes, apenas com a nova máquina Windows 10.


0


origem


Verifique sua unidade externa com o GSmartControl, se os atributos 5.196.197 forem maiores que zero, a unidade externa está morrendo - Alex
@Alex: Qual atributo você quer dizer? - testing
Soa como opção de poder. No gerenciador de dispositivos, encontre o usb, vá para propriedades e verifique as opções para ver se você pode pará-lo de desligar - Dave
@Dave: Já tentei isso sem sucesso - testing
Na maioria dos casos driver seria o mesmo - "dispositivo de armazenamento em massa USB", você pode comparar verificando as propriedades de ambas as unidades externas (clique direito na unidade => propriedade => hardware, em seguida, selecione você dirige e clique em "propriedade", em "geral "guia nomeia o driver do Windows usado para este dispositivo) Se o driver do Windows for o mesmo para ambos, provavelmente é problema de hardware com o adaptador interno USB para SATA dentro do gabinete ou pode ser um cabo / conector USB ruim. - Alex


Respostas: