Questão Erro sem fio Dell XPS L502x após continuar no kernel 3.0.0-16-generic


O kernel do Ubuntu 11.10 64 bits, 3.0.0-16 no Dell XPS L502x tem um problema estranho com a placa Intel Wireless integrada (Intel® Centrino® Wireless-N 1030 BGN, REV = 0xB0) ou drivers iwlagn. Depois de suspender e retomar a rede não funciona em alguns roteadores. Funciona com a antiga Fonera (servindo b / g) mas não com a TP-Link TL-MR3420 (servindo b / g / n ou apenas b / g). Não depende de open / WEP / WPA. Enquanto wifi integrado não estava funcionando eu tentei alsowith USB Wifi stick. Funcionou bem.

Tentando resolver o problema do iwlagn:

  • rmmod / modprobe não ajuda
  • reinicialização não ajuda
  • O syslog exibe que eu recebo o endereço IP, mas depois começa a exibir os erros. A agregação não está ativada para o tid 0 porque load = ... veja abaixo; (esses erros nem sempre são exibidos com essa condição de erro, mas nunca, quando o wifi funciona)
  • Somente coisa que ajuda é a inicialização para o Windows (sorte me - manteve a partição), usando a rede e inicializar de volta para o Ubuntu.

Syslog

Mar 13 19:40:32 xenops avahi-daemon[1053]: New relevant interface wlan0.IPv4 for mDNS.
Mar 13 19:40:32 xenops avahi-daemon[1053]: Registering new address record for 192.168.1.109 on wlan0.IPv4.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> (wlan0): device state change: ip config -> activated (reason 'none') [70 100 0]
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Policy set 'Auto ADOJAANW' (wlan0) as default for IPv4 routing and DNS.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Activation (wlan0) successful, device activated.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Mar 13 19:40:33 xenops NetworkManager[1046]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Get) complete.
Mar 13 19:40:33 xenops dbus[1016]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Mar 13 19:40:33 xenops dbus[1016]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Mar 13 19:40:38 xenops kernel: [135455.414902] iwlagn 0000:03:00.0: Aggregation not enabled for tid 0 because load = 6
Mar 13 19:40:40 xenops kernel: [135457.328053] wlan0: no IPv6 routers present
Mar 13 19:40:48 xenops kernel: [135464.874894] iwlagn 0000:03:00.0: Aggregation not enabled for tid 0 because load = 3
Mar 13 19:40:51 xenops kernel: [135468.396103] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = b0:48:7a:e9:6a:8a tid = 0
Mar 13 19:40:55 xenops kernel: [135472.248823] iwlagn 0000:03:00.0: Aggregation not enabled for tid 0 because load = 5
Mar 13 19:40:59 xenops kernel: [135475.904076] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = b0:48:7a:e9:6a:8a tid = 0
Mar 13 19:41:03 xenops kernel: [135479.908297] iwlagn 0000:03:00.0: iwlagn_tx_agg_start on ra = b0:48:7a:e9:6a:8a tid = 0

1


origem




Respostas: