Questão `emerge --changed-use` não funciona para PHP_INI_VERSION


Todos os documentos do gentoo sobre a instalação do PHP [1] [2] mencionam que eu deveria adicionar uma linha ao make.conf para usar o php.ini 'production'

PHP_INI_VERSION="production"

mas isso não parece fazer nada ... o que mais eu devo fazer para "ativar" essa mudança no sistema?

Edit: @terdon apontou para a minha cegueira, o primeiro link diz o que eu deveria correr depois de editar make.conf ... mas não faz nada

# grep ^display_errors /usr/share/doc/php-5.4.13/*
/usr/share/doc/php-5.4.13/php.ini-production:display_errors = Off
/usr/share/doc/php-5.4.13/php.ini-development:display_errors = On

# grep PHP /etc/make.conf
PHP_INI_VERSION="production"

# emerge --ask --changed-use --deep @world
These are the packages that would be merged, in order:
Calculating dependencies... done!
Nothing to merge; would you like to auto-clean packages? [Yes/No] y

# grep ^display_errors /etc/php/apache2-php5.4/php.ini 
display_errors = On

[1] http://wiki.gentoo.org/wiki/PHPDetalhes

[2] http://www.gentoo.org/proj/en/php/php-installing.xml#doc_chap3


1


origem


Você correu emerge --ask --changed-use --deep @world como sugerido no primeiro link que você postou? - terdon
obrigado @terdon mas não funcionou para o php ini. Adicionei mais informações e atualizei o título. - gcb


Respostas: