Questão AltGr não está funcionando corretamente no vMware


Eu não sei se essa pergunta deveria estar realmente aqui (eu li a StackOverflowHelp, a AskUbuntuHelp e a LinuxAndUnixHelp mas eu não acho que a pergunta se encaixa em nenhum deles, então eu coloco aqui, já que este fórum parece ser o mais apropriado como alguém mencionado aqui: PostInYellow. Espero que possa me ajudar.

Estou trabalhando no fedora18 em um VMware. Até ontem meu teclado estava ok, mas eu estava tentando com o meu chefe para obter o código ASCII estendido ativando as chaves compostas de muitas maneiras (e falhei todas elas hehe). O problema é que agora eu não preciso disso e enquanto estava programando, encontrei o próximo problema: não consigo escrever "{"(NOTA: eu estou usando um teclado espanhol, então eu preciso da tecla AltGr para escrever" {"e"} ") Imagem (Desculpe queria postar a imagem mas até 10 reputacion eu não posso)

A única coisa é que eu desfiz tudo o que toquei ontem, mas houve pouco tempo que o meu chefe tocar meu pc e eu não estava na frente dele e hoje ele está fora, então eu não posso perguntar a ele o que fez.

Se eu tentar escrever "}", escreva-o ok (Então AltGr está funcionando de alguma forma) MAS se eu tentar escrever "{", então ele imprime um bloco em negrito " ´ "então não consigo abrir nenhum loop, o que é um problema muito chato. Eu vejo alguns outros posts como este: Postar porque eu sei que meu chefe deletou a opção inglesa que estava lá (por padrão) e deixou o espanhol sozinho. Eu defini mais 2 opções inglesas: internacional dos EUA com AltGr e internacional dos EUA com AltGr (alternativa) .... mas o resultado é o mesmo (eu aplied as alterações, redefinir o computador ...) E agora eu don Não sei o que mais eu posso tentar resolver esse problema, então qualquer ideia ou dica seria muito apreciada.

Eu também olho em /etc/X11/xorg.conf.d/ para ver se é como antes e parece que está ok

 This file was generated by the Anaconda installer
 Section "InputClass"
     Identifier "anaconda-keyboard"
     MatchIsKeyboard    "on"
     Option "XkbLayout" "es,us"
     Option "XkbVariant"    "cat,"
     Option "XkbOptions"    "grp:alt_shift_toggle"
 EndSection

muito obrigado


1


origem




Respostas: