Questão A linguagem do teclado continua mudando no Windows 10


Então eu recentemente fiz uma instalação limpa do Windows 10 em inglês. Eu configurei para ter idioma de interface do usuário em inglês, mas teclado norueguês. Eu tenho vários problemas com essa configuração:

  1. A linguagem do teclado continua mudando para o inglês constantemente
  2. Não consigo ver a barra de idiomas nem a linguagem pop-up quando eu permuto:

    language toggle popup

Eu limitei o layout do teclado norueguês para Mudança+Alt+0 e isso funciona, mas é chato ter que fazer isso a cada 5 minutos. Também acho estranho não poder ver a barra de idiomas nem na área de trabalho nem na barra de ferramentas.

Alguém tem alguma idéia do que pode estar errado?

Aqui estão algumas imagens das minhas configurações:

settings 1

settings 2

settings 3

No language bar on the toolbar

P.S. A única vez que vejo o pop-up de alternância de idiomas é, na verdade, quando estou desconectado da tela de bloqueio e pressiono Ganhar+Espaço. Nada acontece se eu fizer isso depois de estar logado.


230


origem


Isso me impulsionou UP THE WALL desde que instalei o Windows 10. O layout do teclado alterna esporadicamente conforme eu digito. Eu juro que não toquei no atalho <kbd> Win </ kbd> + <kbd> Space </ kbd>. - Colonel Panic
Alt + Shift também muda de idioma parece. - Mir
E Left Ctrl + Shift altera teclados se mais de um teclado estiver instalado !! Alt + Shift e Ctrl + Shift são padrões de atalho comuns em editores de código e produtos da Adobe (Photoshop, por exemplo). WINDOWS-: essa foi uma escolha pobre e desnecessária de sequestro de atalhos !! Você devia se envergonhar. Ha! Não me pergunto eu tive que continuar "reiniciando"! Eu pensei que este novo laptop / teclado estava quebrado! Obrigado por todos pela Solução :) - SherylHohman
Me entristece que a MSFT ainda tenha problemas básicos de usabilidade. - Bruno Brant


Respostas:


No Windows 10, por padrão, pressionar CTRL+MUDANÇA (ou para alguns ALT+MUDANÇA - obrigado madmenyo) irá percorrer qualquer layout de teclado que você possa ter mapeado e é surpreendentemente fácil fazer isso por engano.

Se você continuar pressionando CTRL+MUDANÇA (ou o que você pode ter mudado para), em seguida, você deve voltar para a configuração correta. (alternativamente reinicie o que eu fiz na primeira vez ;-))

Você pode desativar essa ação de teclado padrão da seguinte maneira:

Control Panel > Clock, Language, and Region > Language > Advanced settings > Switching input methods > Change language bar hotkeys > Change key sequence... > Switch keyboard layout > Not Assigned

a partir de 2016, a localização mudou. (dos comentários)

Control panel > Language > Advanced settings > Switching input methods > Change language bar hot keys 

Esteja avisado, o acima nem sempre funciona - Reinicia e modo de suspensão pode mudar o padrão do teclado (geralmente para os EUA) - Eu não encontrei nenhuma solução de ferro fundido embora criando um novo perfil pode ajudar, embora não seja uma resposta particularmente satisfatória IMHO .

Em uma emergência

WIN+R  
osk

para trazer o teclado na tela pode ajudar temporariamente.

Observe também que é possível desativar isso para que nenhuma combinação de teclas altere o idioma - altere as chaves para "Não atribuído" - veja a resposta abaixo de Mort para mais informações


314



Whaaaat Eu uso Ctrl + Shift com freqüência no Visual Studio. Não é de admirar que meu layout de teclado continuasse mudando. Obrigado! - willem
Para mim isso é realmente ALT+SHIFT - Madmenyo
Ímpar. Talvez eles mudaram isso, mas para mim diz que o atalho para mudar é [windows key] + [espaço], o que parece um pouco mais razoável (e de fato parece ser a única coisa que funciona como atalho de mudança de idioma). - Nyerguds
Para quem vem a este em 2016, parece que o local mudou. Agora está localizado em Control panel//Language//Advanced settings//Switching input methods//Change language bar hot keys - David Metcalfe
para ser precisamente: win + space muda entre todos os pares de idiomas / teclados configurados. alt + shiftmuda apenas a linguagem e ctrl + shift só muda o teclado - Simon Zyx


Se você clicar no link "Alterar as teclas de atalho da barra de idiomas", visível na sua última captura de tela, poderá ver quais chaves estão destinadas a alterar o idioma do teclado.

As configurações padrão são muito fáceis de acertar, ao usar o teclado, mudando assim de repente o idioma do teclado. Alterar as teclas para "Não atribuído" impedirá que o idioma do teclado seja alterado acidentalmente.


15



Sim, esses foram configurados para Shift + Alt originalmente e depois eu mudei para "nenhum". Infelizmente isso não resolveu o problema sozinho, mas veja minha outra resposta. - Nilzor


Acontece que eu tive que configurar um layout de teclado na primeira tela. Você notará que diz "Teclado: Nenhum disponível". Então, clicando em "Opções" aqui, em seguida, "Adicionar um método de entrada" e, em seguida, selecionando QWERTY Norwegian resolveu o caso.

Não sei como consegui instalar o Windows com uma configuração de idioma tão borked. De qualquer forma, aconselho a todos que observem mais de perto as questões linguísticas na instalação inicial.

Pic1

Pic2


12



Depois de tentar obter a escrita à mão para trabalhar em francês (no Canadá), eu tinha 2 versões de inglês (EUA, Canadá) e francês (França, Canadá) instaladas, para não mencionar mais de um método de entrada para inglês dos EUA. Em suma, esta resposta permitiu-me limpar tudo isso bem. - Fuhrmanator


A configuração direta do registro para desabilitar as teclas de atalho de layout de teclado é:

reg add "HKCU\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3

Você também pode querer

reg add "HKCU\Keyboard Layout\Toggle" /v "Language Hotkey" /d 3
reg add "HKCU\Keyboard Layout\Toggle" /v "Hotkey" /d 3

E para novos usuários, tente isso (em um prompt elevado):

reg load HKEY_USERS\temp "%USERPROFILE%\..\Default\NTUSER.DAT"
reg add "HKEY_USERS\temp\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3
reg unload HKEY_USERS\temp

9



O que esses comandos estão fazendo? - kleinfreund
@kleinfreund Como mencionado na primeira sentença, ele desabilita os atalhos de teclado que alternam o layout, para que não possam ser alterados inadvertidamente. - mivk
Obrigado! Executando uma compilação interna e eles removeram completamente a seção de idiomas do Painel de Controle. Eu ainda não consigo entender o que levou a Microsoft a usar uma combinação de chaves comumente usada - samdd
Obrigado! A única maneira que funciona em 2018 para bloquear alternância alt-shift / ctrl-shift, parece que o componente de interface do usuário onde você poderia mudá-lo se foi, não consigo encontrá-lo em qualquer lugar. - jakub.g


Solution1

use esta solução Como desativar a alteração automática de layout de teclado no Windows 8? 

Solution2

Escolha o segundo idioma como padrão. então, quando você mudar para o primeiro, ele permanecerá comutado.

(graças a @SimonSeyock):

win + space muda entre todos os pares de idiomas / teclados.  
alt + shift  muda apenas a linguagem  
ctrl + shift só muda o teclado


5



Solution 1 realmente não oferece uma solução nesse link. Isso resolve um método de entrada não é um idioma de entrada. - msysmilu
alt + shift fez isso por mim. Nada mais funcionou - Ghoti and Chips


Meu problema: eu tenho 3 idiomas (layouts de teclado) instalados. Quando vai dormir no Windows 10, depois de acordar, ele sempre retorna ao "idioma principal", em vez de manter o último definido. Eu considero isso um bug.

Solução:

  1. Aberto Control Panel\All Control Panel Items\Language.
  2. Clique em Advanced Settings.
  3. Sob Switching input methods, Verifica a Let me set a different input method for each app windows.

Isto irá manter a língua quando vai dormir e voltar.


5



Obrigado. Isso resolveu meu problema com o layout do teclado sempre voltando ao "padrão" após a reinicialização e depois de dormir. Eu também tenho 3 layouts de teclado instalados. Inglês, porque funciona melhor com algum jogo e dois suecos. Qwerty normal e dvorak. - Albert Veli
Eu tive um problema semelhante, resolvi isso definindo meu teclado diretamente sob a linguagem principal: veja superuser.com/a/1322521/97570 - jakub.g


2018 resposta:

Eu tive o mesmo problema, tentando usar o teclado polonês com a linguagem de interface do usuário em inglês do Windows.

Toda vez que eu trancava o computador, ele voltava para o teclado dos EUA.

O problema era que eu estava tendo o teclado polonês sob o idioma polonês, onde, na verdade, o que eu realmente queria era um teclado polonês sob o idioma inglês.

Eu removi o pacote de idioma polonês, adicionei o teclado polonês no idioma inglês e removi o teclado americano do idioma inglês - veja a imagem abaixo:

Windows 10 (2018) language preferences

Então, em suma, o truque é adicionar o teclado desejado como o único teclado no idioma padrão.

(Isso funciona para mim, porque eu geralmente digito em inglês, só que às vezes quero inserir em polonês, mas posso fazer isso sem mudar o teclado, já que o teclado polonês é totalmente compatível com o US QWERTY).


4