Questão upload de iso do ovirt não visível no webgui


Eu criei recentemente um host ovirt com um motor auto hospedado. Eu uso nfs compartilha como um back-end de armazenamento (freenas). A configuração foi perfeita e consegui acessar o webgui. Tudo parece funcionar bem, exceto o upload iso.
Depois de fazer o upload de uma iso (debian-8.4.0-amd64-netinst.iso) usando o ovirt-iso-uploader, eu queria configurar uma VM. Infelizmente, não consegui escolher um iso para anexar (Anexar CD). Além disso, a guia de imagem sob o armazenamento iso mostra "Nenhum item para exibir", mesmo depois de pressionar o botão de atualização. Após a reinicialização do motor, colocando o domínio iso para manutenção, desanexar, anexar novamente, habilitar e fazer o upload de outra imagem, obtive o mesmo resultado.
Depois de pesquisar um pouco os logs, pude encontrar o seguinte em vdsm.log:

jsonrpc.Executor / 1 :: INFO :: 2016-08-16 09: 12: 51,066 :: logUtils :: 51 :: dispatcher: :( wrapper) Executar e proteger: getFileStats, Resposta de retorno: {'fileStats': {u 'debian-8.2.0-amd64-netinst.iso': {'status': 469, 'ctime': '1471271972.0', 'tamanho': '258998272'}, u'debian-8.4.0-amd64-netinst. iso ': {' status ': 469,' ctime ':' 1471263076.0 ',' size ':' 258998272 '}}}

Isso aparece toda vez que tento listar as imagens no webgui.
Eu também posso encontrar o caminho montado e arquivos no hipervisor:

-rw-r -----. 1 raiz do root 258998272 15 de agosto às 14:11 /rhev/data-center/mnt/hades.gwitter.ch:_mnt_Master_iso/a93e3450-42e1-494b-a3bc-12756f16ed29/images/11111111-1111-1111-1111-111111111111/debian- 8.4.0-amd64-netinst.iso

Eu realmente não sei, se estou acertando um bug ou se eu perdi alguma coisa.

Informações adicionais:
Eu usei centos7 como abase os e o pacote ovirt-engine-appliance-3.6-20160623.1.el7.centos.noarch para instalar o motor.
O domínio iso foi criado durante a configuração egine hospedado no mesmo host nfs que o mecanismo hospedado é colocado.
Versão do motor de aspiração: 3.6.6.2-1.el7.centos


1


origem




Respostas:


Acabei de encontrar o meu problema!
A pasta iso images precisa ser de propriedade 36:36 (user vdsm group kvm). Basta usar o chown no seu servidor nfs para ajustar suas permissões:

chown -R 36:36 a93e3450-42e1-494b-a3bc-12756f16ed29 / images / 11111111-1111-1111-1111-111111111111

Também as imagens recém-enviadas serão mostradas no webgui agora.


1