Questão Por que o Opera cria uma guia privada quando clico em um link em outro programa?


Eu tenho o Opera como meu navegador padrão. (Isso está em um sistema Windows 7.) Assim, quando clico em um link em algum programa externo, como o Thunderbird ou o Acrobat, a página é carregada em uma nova guia na janela do Opera.

Por algum motivo, a nova guia que é aberta é sempre uma guia privada - o que significa que ela não aparece no meu histórico ou na minha lista de guias fechadas quando eu a fecho.

Por que isso está acontecendo? Ou, mais precisamente, como posso alterar minhas configurações para que isso não aconteça?


1


origem


Eu tenho o mesmo problema. Acabei de remover esse "% 1" e funciona: P


Respostas:


Meu palpite é que a associação do Windows para o arquivo HTML de alguma forma configurou o Opera para iniciar com a opção "--newprivatetab". Você pode consertar isso abrindo o Opera, indo em Configurações -> Preferências, e depois na aba Avançado. Vá para Programas e clique no botão "Detalhes". Clique em Selecionar tudo e, em seguida, clique em OK.

Porém, se você não tem medo do registro, o valor real é mantido em:

[HK_Classes_Root\Opera.HTML\shell\open\command]

2



Um bom pensamento, mas o valor desse comando de registro é apenas "C:\Program Files (x86)\Opera\Opera.exe" "%1". Estranhamente, porém, se eu executar isso a partir de uma linha de comando, ele não abrirá em uma guia privada .... - Brooks Moses
No entanto, investigando um pouco mais - acho que o que aconteceu é que as associações de URL HTTP e HTTPS (e não as associações de arquivo HTML) foram configuradas de forma estranha. Fui embora a caixa de diálogo de configurações "associar programa com esta extensão / protocolo" ao Painel de Controle do Windows e selecionei "Opera" para ambos (embora pareça já estar definido), e agora as coisas abrem em abas não privadas . Então, problema resolvido. Obrigado! - Brooks Moses
@Brooks Ahah! Um bom achado. - SysAdmin1138
Eu tive esse problema com o Opera 10.63 no Windows 7 também. Eu só notei isso há alguns dias, mas não me preocupei em consertá-lo até que eu vi essa pergunta e solução. Alguém sabe a causa disso? A culpa é do lado do Opera ou do Windows? - galacticninja
Eu tenho o mesmo problema. Acabei de remover esse "% 1" e funciona: P


Eu tive o mesmo problema. Minha solução: Basta abrir o IE, torná-lo o navegador padrão. Em seguida, abra o Opera e re-escolha o Opera como o novo navegador padrão. É isso aí.


0