Questão Atualize o PHP 5.1.x para o 5.3.x com o XAMPP para Windows


Usando o Windows XP SP3. Eu instalei o xampp para d: \ xampp.
Eu comecei e tudo funcionou bem (pelo menos as indicações eram boas).
Eu quero usar o MediaWiki e ele diz que ele não pode funcionar com PHP5.1, que é a versão instalada pelo XAMPP.

Eu segui as instruções que encontrei em esta thread, mas agora o serviço Apache não inicia.
O painel de controle do XAMPP diz que o serviço Apache começou apesar de não mostrar uma indicação de running.

Eu não estou familiarizado com o XAMPP. Não sei onde procurar o erro.

Questão: Como faço para atualizar para o PHP 5.3


Eu devo ter ficado cego ou algo assim ...
Reinstalar o XAMPP revelou que a versão do PHP é 5.3.1 como sugerido por itadokresposta

Meu erro foi que eu verifiquei o phpmyadmin para a versão e declarou a versão do servidor e não a versão do PHP.


1


origem




Respostas:


Olhando para o notas de lançamento, parece que o último XAMPP vem com o PHP 5.3.1. Então sugiro que você faça o download da última versão do XAMPP.


2



vadio. Eu devo ter baixado uma versão antiga ... vou tentar e voltar. - Shaihi
Olhando para isto, eu instalei o XAMPP versão 1.7.3 (supostamente para ter o PHP 5.3), mas no phpmyadmin ele mostrava um status de uma versão antiga do PHP. Eu estou reinstalando para ver onde eu errei. - Shaihi


Eu recomendo fortemente baixar o bitnami stack para Mediawiki Aqui. Isso economizará mais problemas ao instalar o próprio mediawiki.


3



Parece bom. Eu já resolvi meu problema, então não vou usar isso por enquanto, mas obrigado - Shaihi


Talvez você possa simplesmente instalar uma nova versão do xampp? Eu não sei onde você está usando o xampp. Eu é apenas para um projeto, você provavelmente pode simplesmente instalar uma versão mais recente. E na sua janela do XAMPP existe uma opção para clicar em Setup? Talvez você possa realocar sua pasta do xampp.

Me avise.


2