Questão Como faço para atualizar o VIM para o 7.2 quando o 7.1 é a única versão listada no meu aptitude?


Eu tenho dois servidores Ubuntu em que estou tentando atualizar o VIM para 7.2, mas apt-get install vim apenas lista a versão 7.1 que já está instalada. Mesmo com uma pesquisa no aptitude.

Eu me certifiquei de que minhas fontes estão atualizadas, mas parece que elas estão puxando de 'intrépido' ou 'hardy', o que eu assumo é parte do problema.

Como devo proceder para instalar o 7.2?


2


origem




Respostas:


Se eles não estiverem em seus repositórios e você estiver usando os repositórios mais atualizados, sempre poderá criá-los a partir do código-fonte. O problema com isso é que você não receberá atualizações para essa versão do seu gerenciador de pacotes se ele for compilado a partir da origem.


1



Bem, eu estou supondo que o 7.2 existe algum lugar nos repositórios do Ubuntu, certo? Eu acho que estou apenas puxando de um antigo. - rspeicher
Talvez sim, mas pode ser construído em bibliotecas mais recentes do que você instalou. Para ser seguro, você deve (1) construir a partir da fonte contra o que você já tem instalado (você pode usar help.ubuntu.com/community/CheckInstall integrar isso melhor com o apt); ou (2) instala o novo binário vim que você encontra, além dos novos binários de todas as suas dependências, além dos novos binários de todas as suas dependências e tudo o que depende deles, mais ... - dubiousjim