Questão Evitar que eventos do sistema aumentem o volume principal


Eu tenho um laptop que uso freqüentemente durante palestras. Para fazer isso eu quero que o som seja mudado, por isso mudo o volume principal / reduza para 0%

Então, quando algo dispara uma mensagem do sistema como "O cabo de alimentação foi desconectado", o volume principal é automaticamente ampliado para 100% e não é ignorado para reproduzir um som de notificação.

Como faço para desativar esse recurso?

Até agora eu tenho apenas a solução alternativa de silenciar / reduzir o volume do alto-falante do PC, o que não é afetado pela mensagem do sistema. No entanto, isso tem a desvantagem de precisar abrir o alsamixer (como o controle de volume não é visível no KMix por algum motivo) e ligá-lo enquanto eu quiser o som do alto-falante e então devo me lembrar de desligá-lo quando não quer mais (o que não é feito através de teclas multimídia "normais").

O laptop é um Lenovo G780 com um Controlador de Áudio de Alta Definição da Família de Chipsets Série 7 / C210 da Intel Corporation.

Eu instalei pulseaudio.


2


origem


Qual fabricante de hardware? Qual sistema operacional (acho que alguma distribuição Linux rodando o KDE, como você menciona o KMix)? Se este último, qual configuração de áudio (servidores de áudio adicionais como o Pulso ou simplesmente alsa?)? Nunca aconteceu comigo, usando o Ubuntu no meu laptop (MSI e Lenovo) ... - Johannes H.
@JohannesH. Eu adicionei os detalhes solicitados. Deixe-me notar que eu tive uma instância do Linux Mint usando o KDE rodando neste hardware e o problema nunca me aconteceu lá. - Nobody
Colocar uma recompensa nisso porque eu ainda estou tendo este problema no Kubuntu 15.04, e eu tenho que abrir o alsamixer para definir um volume máximo rígido, o que é uma dor. - naught101
@ naught101: Está no mesmo hardware ou isso também difere? - Nobody
HP zBook 14. Mas é um problema de software, tenho certeza - algo a ver com como o Pulseaudio lida com novos eventos de volume. Eu estava olhando para ele, tentando encontrar uma solução há alguns meses, mas agora não consigo me lembrar do que foi chamado e não consigo encontrar nada relevante ... - naught101


Respostas:


Para ser pragmático, uma solução pode ser cortar o plugue de 3,5 mm de um par de fones de ouvido e conectá-lo ao laptop quando o silêncio for desejado!

Como alternativa, observe que o alsamixer tem uma versão de linha de comando, amixer (pacote alsa-utils no fedora), para que você possa escrever um pequeno script para silenciar ou ativar o alto-falante.

Listar os dispositivos disponíveis:

$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: Device [USB Audio Device], device 0: USB Audio [USB Audio]
...

Listar os controles para esse cartão:

$ amixer -c 0 scontents
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 52
  Mono:
  Front Left: Playback 26 [50%] [-27.00dB] [on]
  Front Right: Playback 26 [50%] [-27.00dB] [on]

Definir o volume e o estado de sigilo:

$ amixer -c 0 set 'PCM' '50%' mute

O bug parece ser kde Bug 324975 "O volume é restaurado para 100% após cada evento knotify", publicado pela primeira vez em 2013-09-16 e encerrado em 2014-12-04 com Status RESOLVIDO CORRIGIDO, mas com muitas pessoas ainda tendo problemas e adicionando seus comentários mesmo agora.

Entre as sugestões de soluções alternativas, que dependem muito do seu sistema, estão:

  • Conjunto flat-volumes=no em /etc/pulse/daemon.conf

  • Desativar esses sons em ~/.gtkrc-2.0 ou ~/.config/gtkrc-2.0 ou $XDG_CONFIG_HOME/gtk-3.0/settings.ini com

    gtk-enable-event-sounds=0
    gtk-enable-input-feedback-sounds=0
    
  • Remova o pacote libcanberra-gtk2 sound-theme.

  • Use o backend do gstreamer em vez do PulseAudio.

  • Em 15.04, ative o controle de volume em Systemsettings -> Application and System Notifications -> Configurações de reprodução e defina outro que não seja 100%.


2



Na maioria dos contextos, faço exatamente isso: conecto meus fones de ouvido para evitar que o som seja ouvido. No entanto, isso é 2015! Até agora, deveríamos ter descoberto como dizer a um computador o que fazer. Até mesmo o pequeno script é apenas uma solução alternativa e nenhuma solução. Eu posso ver que pode ser um recurso para aumentar o volume para que os eventos do sistema sejam ouvidos, mas, pelo menos para mim, não é desejado, portanto, deve haver uma opção para desativá-lo. Além disso, este não foi um problema em outros sistemas, portanto, é claramente um bug que deve ser corrigido em vez de contornado. - Nobody
Eu não quero silêncio. Eu só não quero ser ensurdecido quando há um novo sino do sistema. Eu também não quero ter que definir manualmente o volume PCM. Eu já posso fazer isso com o alsamixer, se necessário. Estou apenas procurando uma maneira de evitar que os sons do sistema aumentem o volume, em relação à última vez que reduzi o volume. - naught101
@ naught101 parece ser um bug kde conhecido / fixo. veja minha edição. - meuh


mesmo problema no archlinux, encontrei a solução aqui:

http://userbase.kde.org/Sound_Problems/es#Can.27t_mute_event_.28system.29_sounds_and_other_KMix_strange_problems

Agora com o KDE 4.10+, o PulseAudio é ativado pela sessão do usuário e podemos   verifique isso com o seguinte comando

ps -ef | grep pulseau

Exemplo de saída:

sergio    1880     1  0 12:15 ?        00:04:01 /usr/bin/pulseaudio --start --log-target=syslog

Inserindo os seguintes comandos

killall kmix
rm -rf .pulse/
rm -rf .pulse-cookie 
rm -rf .config/pulse/
kmix

Corrigido este problema. Configurações antigas do PulseAudio, podem fazer isso   problema, se criarmos um novo usuário, não teremos esse problema.


-1



Embora o link possa fornecer uma resposta, ele pode ser rapidamente desatualizado. Por favor inclua os pontos principais do link na sua resposta. obrigado - Matthew Williams
No começo eu não dirijo nenhum pulso em execução (e nem kmix), mas eu apliquei os passos (embora nenhum pulso / também estivesse lá) e nada aconteceu. Eu desconectei e voltei em um tudo estava como sempre (as notificações de evento aumentaram o volume). Desta vez pulseaudio estava ao redor e kmix também, então eu tentei novamente (ainda sem pulso) e parecia funcionar. No entanto, agora eu não tenho nenhum evento de som (mesmo quando o volume estava ligado). Então eu instalei algumas atualizações e reinicializei e agora os sons do evento retornam o volume novamente e a correção não funciona (eu também estou perdendo o .pulse / e o .pulse-cookie agora). - Nobody